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DOWNLOADING
Head to the ELAN website and download the appropriate version of the program for your
computer:
http://www.lat-mpi.eu/tools/elan/
There you can also download PDFs of the manual and a somewhat outdated “getting started”
guide (geared toward PC users). Several of the current document’s sections replicate the content of
that guide, but here I gear things more towards Mac (OS 10.4) users.
STARTING A NEW ANNOTATION FILE
The main files you will manage when using ELAN are (1) a movie file that you wish to annotate,
(2) a WAV audio file matched with the movie, and (3) the ELAN Annotation File (file type
*.eaf), or “EAF file”, which is the text file ELAN creates and modifies as you use the program and
annotate your movie.
For best organization, create a separate folder that will contain all of the files associated with a
particular movie clip, and give the EAF file the same name as the clip it refers to (only the
extension should differ). For example, you could have a video clip called Gesture_clip.mov, a
matched audio file called Gesture_clip.wav, and you would save the EAF file in ELAN as
Gesture_clip.eaf and place them all in a folder you might call Gesture_clip ELAN.
If you already have the video and audio media on your computer and you don’t wish to make
separate copies to use with ELAN, that’s fine: the media does not need to be in the same place as
your EAF file, and using ELAN will not do anything to your media files since ELAN creates its
own files for your annotations. Just be sure to keep track of all your file locations and you should
save your EAF file with the same name (before the extension) as the movie clip it refers to.
• Your movie file must be a self-contained movie, not a file which merely references a
media file in a separate location.

Basic ELAN tutorial (version 3.0 for Mac)

• A separate audio file is only necessary if you wish to see the audio waveform in ELAN’s
Waveform Viewer. The audio you actually hear during playback is the audio embedded
in the movie file, not the WAV file you import and view in ELAN.
Establish the location of your media (preferably, place it in a pre-named folder where you will
save your ELAN files).
Start ELAN.
Choose File > New... (or press Cmd-N)
• The above means “choose ‘New’ from the File Menu”, or press Command-N by holding
down the Command key and pressing N.
• The Command (Cmd) Key has the squiggly

symbol (and an apple) on it.

• As you navigate the menus, you will see key commands listed next to many of the items,
which can be deciphered as follows (you should memorize the most useful commands):
= Hold Shift

= Hold Option

= Hold Cmd

• Several important key commands also make use of the Control (Ctrl) Key.
In the List on the left, navigate to your movie file.
• If it is a *.mov file (Quicktime movie) rather than a *.mpg file (MPEG movie), you now
need to change the selection in the “File Format” menu below: change it to “All Files” to
enable you to select both *.mov files as well as *.wav audio files.
Click on the >> button in the middle to “send” these files into the list on the right.
• Optionally, you can now also select an ELAN Template File (file type *.etf), or “ETF
file” to form the basis of the Tiers, Types, and Controlled Vocabularies of your new
session. This is a quick way to use the same structure as one of your previously
annotated projects, provided you created a template file from it (more on this later).
Click OK and the session initializes. You will probably notice a graphical glitch where pieces of
the video window are printed in the wrong part of the screen and stick there. You can make this
stuff disappear by dragging windows over it (try switching back and forth between applications by
holding Cmd and tapping the Tab key).
Before getting started, choose Save or Save As... from the File menu to create your EAF file.
The program may choose its own application location as the default place to save your file – Don’t
save your file here! Instead, use the pull-down menu to navigate all the way to the top level of the
hard drive, then dig down until you find your user folder and the folder where you intend to save
your ELAN files. The best way to name your file is to simply click on the name of the movie file
you have stored here, which copies it up into the text box. Delete the extension part of the copied
name (e.g., “.mov”) and save the file and ELAN should automatically append the *.eaf extension
to the file it creates.
• Always remember to save your EAF session file before choosing to quit the program.
ELAN is not to be trusted when it comes to checking whether or not you have unsaved
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changes when choosing to quit, and even if it catches and asks you, it may not save your
changes properly in this situation.
• Even more strangely, if you choose to quit the program there is no way to cancel this
action. Even if it catches unsaved changes and asks whether you would like to save
them before quitting, if you click “Cancel”, the program will immediately quit
without saving changes – this is not how most programs behave in this situation!
• It behaves more normally when you choose the Close command (from the File menu or
by pressing Cmd-W or by clicking the red circle in the upper left corner of the window).
If your session has unsaved changes, it will ask you whether you wish to save, and this
time, clicking “Cancel” takes you back to your session rather than closing it without
saving. You will notice, however, that the ELAN window does not completely disappear
after a Close command – it just becomes blank (you cannot make it completely go away
without quitting the program).
• If you just want to get your session out of the way without closing it or quitting,
remember you can always hide the program by pressing Cmd-H, or minimize the
window by clicking on the yellow circle.
To open an existing EAF file, you must start the program and choose Open from the File menu,
and navigate to your EAF file. You cannot initialize an EAF file just by double-clicking on it.
The best thing to do first is to get a list of ELAN’s keyboard shortcuts: View > Shortcuts...
You should print this file for your reference, and many of these functions are covered in detail
below. Note that “Alt” means the Option key. The key commands are the same as for PC, except
that all cases of “Command” on Mac are instead “Ctrl” on PC.
But to start and stop simple playback, you press Ctrl-Space (just like on PC). It is not Cmd-Space
(because this normally activates the Mac OS 10.4 “Spotlight” function).
• Not found in the Keyboard shortcuts is the following: to drag the timeline view left or
right, hold Option and drag left or right on the numbers in the timeline.
• Another important use of the Ctrl key is for Mac users lacking a two-button mouse:
every time you wish to Rt-click something, simply hold down Ctrl and click the mouse.
LINKING AND UNLINKING MEDIA
Choose Edit > Linked Files...
Here you can see (among other things) the media files which your ELAN session is working with.
You can, for example, add the WAV audio file of your movie to get a Waveform View, if you
didn’t do this when initially creating the session.
You might also decide that your movie file has too high a resolution for ELAN to handle
smoothly. If you want better playback quality, it makes sense to create a new version of your
movie that has much smaller dimensions – it doesn’t need to be full-size given that the ELAN
window displays it quite small anyway (although you do have the option of detaching the movie
window and displaying it larger, if you have room on your screen or a separate monitor).
Suppose you have already annotated a portion of your movie in ELAN, but you decide the
playback is too jerky and you want to switch it with a version of the movie with smaller
dimensions: use the Linked Files... dialog to remove the large movie and add the smaller-sized
version instead (make sure the small movie has the same starting point as the original!).
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PREPARING A MOVIE FILE FOR USE IN ELAN
The following illustrates one possible route for creating a small-sized movie file for use in ELAN
on a slower computer. I started out with data recorded onto MiniDV tape, which I had originally
captured into Final Cut Pro and exported as a QuickTime movie using the “Photo-JPEG” setting
on “Medium” quality. This is not necessarily the best codec to use nowadays, but Photo-JPEG
files can be created much more quickly than with certain newer, more efficient codecs (like the
default H.264), and they seem to have adequate image quality and reasonably small file size,
without the long wait associated with H.264, MPEG-4, and various others.
Using Final Cut Pro:
• I import the movie into Final Cut Pro (Cmd-I), and double click its icon once the file
appears in the Browser (upper left of the screen). The movie appears in the Viewer.
• The original size of my MiniDV movie was 720 x 480 in a 4:3 aspect ratio, which means
it requires “square pixels” to appear correctly. Since most programs (like QuickTime
Player and ELAN) do not use “square pixels”, I actually want my movie to be exported
as some division of 640 x 480 in order to achieve the proper 4:3 ratio in those programs.
• 100% size would be 640 x 480, but I will choose 320 x 240 instead for better playback.
• Click File > Export > Using QuickTime Conversion... (not “QuickTime Movie...”)
• At the bottom, “Format” should be “QuickTime Movie”, and I click on “Options...”
• At the top (for Video), I click “Settings...” and choose “Photo - JPEG” at Medium
quality since this is the same format as the file I just imported. For “Size...” I make sure
to choose 320 x 240 QVGA (don’t leave it as “current” even if it claims this is already
320 x 240, since doing so tends to export the file as full size anyway). I don’t tell it to
“preserve aspect ratio”, since I want my chosen dimensions to force it into the 4:3 shape.
• For Sound I choose AAC (using the default 44.1 kHz at 128 kbps).
Using QuickTime Player (you probably need to have QuickTime Pro installed to do this):
• I load the movie into QuickTime Player, and check its history by choosing Window >
Show Movie Info (Cmd-I). In this case it tells me that the file has 720 x 480 pixels and
was created using the “Photo - JPEG” codec, with AAC audio. But I note that the picture
appears stretched horizontally, which means that for optimal use in QuickTime Player
(and ELAN) it needs to be re-encoded in some division of 640 x 480 (4:3 aspect ratio).
• I click File > Export... It should say “Movie to QuickTime Movie” at the bottom for
“Export:”, and I click the “Options...” button, which brings up a window just like the
one in Final Cut Pro:
• For Video I click “Settings...” and choose “Photo - JPEG” at Medium quality. For
“Size...” I pick “320 x 240 QVGA”, which should provide better playback in ELAN
than 640 x 480, and I do not check the “preserve aspect ratio” box since I want the
export to end up with a 4:3 shape instead of the stretched one I started with.
• For Sound I choose AAC (using the default 44.1 kHz at 128 kbps).
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THE WAVEFORM VIEWER
To use the Waveform Viewer in ELAN you need to create a separate WAV file of the soundtrack
of your movie. Only a *.wav file will do (an AIFF file will not work). This will be a sound file
that you will see rather than hear, since ELAN still plays your movie’s own embedded audio track
out of the computer speakers. Be sure that the WAV file exactly matches the movie’s audio
track, otherwise the waveform you see will not match up with the sounds you hear.
• The best way to ensure a perfect match is to create your WAV file directly from the
movie’s audio track:
• Load your movie into QuickTime Player and choose File > Export...
• At the bottom next to “Export:”, select “Sound to Wave” from the pull-down menu.
Click “Options” to be sure that the current settings are correct (normally you will want
16-bit stereo at 44.1 kHz). Save it with the same filename as the movie (but with *.wav).
In ELAN, the Waveform Viewer should appear once you initialize a session and include a WAV
file, or once you add a WAV file by using the Edit > Linked Files... command.
To hide the Waveform Viewer, click on the tiny upward triangle in the upper-right corner. To
make it reappear, simply click the downward triangle. Sometimes it is much too large when it
reappears and fills up all the space where your annotations should be – if this happens, click and
drag up on the tiny dot at the center of the bottom of the window to decrease the size of the
Waveform Viewer and bring your Annotation Timeline back into view.
Rt-click (or Ctrl-click if you have a one-button mouse) on the Waveform Viewer to get a menu:
• Zoom: choose the horizontal time-scale displayed
• Vertical Zoom: increased the vertical “severity” of the peaks of the waveform, which makes
it easier to see the details. You will often want this at 200-300%.
• Stereo Channels: choose how to display the separate channels of your audio file. Separate
gives you two separate waveforms, Merged should combine the two into the waveform of a
mono sum of the signals, but instead it appears to display just the Left channel. Blended offers
the most pleasing display, with both channels on a single timeline displayed in different colors
(green for Left, blue for Right).
• Connected: when this is checked, the zoom levels of the Waveform Viewer and the
Annotation Timeline below are kept the same (when one is changed, so is the other). When it is
not checked, the crosshairs of the timeline and waveform viewers are kept separate and may
appear in separate places on the screen, although they still represent the same moment in time.
Unfortunately all of the above reset to their defaults every time you re-open your session.
DETACHING THE VIDEO WINDOW
Rt-click on the video window and choose Detach. You can now resize the window and move it to
a different location (such as a separate monitor). Especially useful if your video is high resolution
and you want to view it larger.
Warning: you can re-attach the video window by Rt-clicking it and choosing Attach, but this
occasionally causes the program to crash or to stop responding to key commands. Always save
your work before attempting to re-attach the video window, and restart the program if necessary.
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EXPORTING THE CURRENT FRAME AS AN IMAGE
Rt-click on the video window and choose Save Current Frame As Image...
If it works, it will ask you for a filename and will automatically append the *.jpg extension, and
then save your image (or the program may crash at this point). But frequently it will give you a
warning message that contains no text, instead of asking for a file name.
• Given how buggy this feature is, you are better off using the simple screen capture built
into the Mac OS: press Shift-Cmd-4 to turn the mouse pointer into a crosshair, click and
drag it carefully to form the rectangle that will be your image file, and let go. An image
file in *.png format will appear on your desktop, called “Picture 1”. If you want to abort
the process before creating the file (e.g. if you started dragging the crosshair from the
wrong place and want to try again), simply press Escape.
• If you do attempt to use ELAN to export the current frame, always save your work first.
THE TIMECODE DISPLAY
Click on the timecode below the video window (or press Cmd-G for “go”) to enter in a value and
immediately jump to that position in the video. It defaults to a millisecond display (after the
decimal) rather than frame numbers, but if you need to refer to frames you can do the following:
Rt-click on the timecode and hold down the mouse button (otherwise the pop-up menu will
disappear before you can do anything) choose Time Format > NTSC (drop frame) as your
format, which is appropriate for video recorded at 29.97 frames per second.
If you choose the wrong Time Format (e.g. PAL when your video is NTSC), it will not affect
video playback or movement by single frames using ELAN’s controls, it will simply cause the
timecode to be displayed incorrectly.
• NTSC is the broadcasting standard of North America and Japan, in contrast to PAL (the
European format, which runs at 25 fps). Historically, color video was consigned to 29.97
fps in order to avoid conflict with 30 fps B&W signals. As a result, video clips playing
at 29.97 fps (including material collected on MiniDV for gesture research) will take very
slightly more than one second for every 30 frames of video, even though the display
cycles to its next second every 30 frames. The “drop frame” in the name refers to the
fact that at the start of each minute of video, the first two numbers are skipped: e.g.
00:00:59:29 is followed by 00:01:00:02, because frame numbers “00” and “01” are not
used. This convention has no effect on the video itself, only on the timecode used to
track it. The numbers are dropped from the timecode in order to keep it from falling
behind “actual time”.
BASIC NAVIGATION, MAKING SELECTIONS
Ways to move the cursor/crosshair (the red vertical line) around in the annotation timeline:
• Ctrl-Space or

: Start and stop playback.

• Cmd-Option-R: Toggle the playback rate between Normal (100%) and a preset value, which
is set to 50% by default. That is, by default this will switch you back and forth between fullspeed and half-speed playback, useful for slowing things down to examine in more detail.
6

Basic ELAN tutorial (version 3.0 for Mac)

• Cmd-Left / Cmd-Right or

/

: Move the cursor back and forth by one frame.

• Shift-Left / Shift-Right or

/

: Move the cursor back and forth by one second.

• Shift-Cmd-Left / Shift-Cmd-Right or
/
: Move the cursor back and forth by
the length of time taken up by one pixel on your computer screen. This value depends on your
zoom level, but is often very small (smaller than a frame, at 100% zoom).
• Cmd-Page Up / Cmd-Page Down or
/
: Move the cursor back and forth by
one “scrollview” (the width of your timeline that is currently visible in the ELAN window,
which depends on your zoom level).
• Cmd-B / Cmd-E or

/

: Move the cursor to the very beginning or very end.

• Cmd-G or click on the timecode below the video window: Enter a timecode value to
immediately jump to that position on the timeline.
• You can also click anywhere within the Annotation Density Viewer, which is the skinny bar
just above the Timeline and Waveform Viewer. Its width represents the entire Timeline.
MAKING SELECTIONS
• Click and drag the mouse to create a selection (light-blue highlighted section).
• Cmd-K or check the Selection Mode box to toggle Selection Mode on and off. With this
mode on, any movement of the cursor creates a selection. So you can use this mode to make
selections using the above navigation controls, rather than clicking and dragging the mouse.
This is especially useful if you want to fine-tune a current selection (e.g., by moving its
endpoints back and forth by single frames).
• Shift-Option-C or

: Clear the current selection (the blue highlight disappears).

NAVIGATING AROUND SELECTIONS
• Cmd-/ (“Command-Slash”) or
/
: Move the cursor to the beginning or end
of the current selection. Using this key command combined with Selection Mode, you can
quickly fine-tune the position of both ends of a selection.
• Shift-Space or
: Play the current selection. Playback will stop when the cursor
reaches the end of the selection. If the cursor has been placed in the middle of the selection,
playback will start from the cursor rather than from the beginning of the selection.
• Shift-Ctrl-Space: Play around the current selection. Playback starts slightly before, and
ends slightly after, the current selection. If the cursor has been placed in the middle of this
interval, playback will start from the cursor rather than from before the start of the selection.
• Cmd-L or check the Loop Mode box to toggle Loop Mode on and off. With this mode on,
the above two commands will loop playback rather than stopping when the cursor reaches the
end of the selection interval.
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ADJUSTING PLAYBACK OPTIONS
• In the Options menu, choose Play Around Selection... to set the value of the “pre-roll” and
“post-roll” time added to the beginning and end of a selection when you use this playback
command.
• From the same menu, choose Rate And Volume Toggle... to set the values which you will
toggle to when using the associated commands (Cmd-Option-R to toggle the playback rate).
CREATING ANNOTATIONS
• Cmd-Option-N: Create a new annotation at the selection, on the Active Tier (the Active
Tier’s name is red and underlined). Do not use Option-N for this command, because it doesn’t
work (Mac users should cross out “Alt + N” from the list of key commands). If you use
Option-N (i.e., without holding down the Cmd key as well), nothing will happen except that
now some key commands will no longer work (such as Cmd-Left / Cmd-Right for moving
around by single frames). To restore normal operation, switch to a different Application (such
as the Finder) and then back to ELAN – you do not need to quit and restart.
Once you have initiated the above command, an Inline Edit Box appears, filling the width of the
new annotation. You can type in text hear or choose a value (if this tier uses a controlled
vocabulary).
• You must press Cmd-Return to commit this text into the annotation.
• Once the Inline Edit Box appears, you can press Shift-Return to toggle between it and
a larger text window. Text can be typed into either one and committed using CmdReturn. With the larger text window, you have the option of choosing a different
character set under Select Language.
• To cancel the text you’ve entered and create a blank annotation, simply press Escape
or click anywhere outside the annotation.
There are a few other, equivalent ways to create annotations:
• You can press Option-A to open the Annotation Menu, then navigate up and down with
the arrow keys and press Return on the option of your choice (or simply click on the
menu and navigate with the mouse). The first item in the list is the same command as
Cmd-Option-N. Opening this menu is especially useful if you wish to use some of the
other, less frequent commands without having to remember the keyboard shortcuts. If
you wish to close the menu without doing anything, press Escape or click away from it.
• You can double-click your selection at the desired tier to create an annotation there,
even if that tier is not the Active Tier. You can also Rt-click that same spot and choose
“New Annotation Here” from the pop-up menu to accomplish the same thing.
Once you have several annotations, you can navigate to each one to make it Active:
• The Active Annotation becomes highlighted in dark blue.
• Rt-click an annotation and choose Active Annotation Bold from the pop-up menu
to make it even more clear which annotation is active.
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The selection will also jump to encompass any annotation you make active, and the cursor will
jump to the start of the annotation.
• Option-Left / Option-Right / Option-Down / Option-Up or
:
Navigate around your various annotations, making each one active in turn. This is also a good
way to quickly move around your timeline.
• Because making an annotation Active also creates a selection, blank annotations are a good
way to mark out important selections that you wish to use in the future.
• Inactive annotations either appear black, if they are time-alignable, or yellow, if they are not
time-alignable. The latter is a type of annotation that can appear on a dependent tier (a tier
which is dependent on a parent tier – more on this later).
MORE ADVANCED CREATION OF ANNOTATIONS
You can create an annotation directly adjacent to an existing one:
• Navigate to an annotation (which makes it active). Press Cmd-/ (or click the button) to
get the cursor to either the beginning or the end of this selection, as desired. This will be
one of the boundaries of your new annotation. Press Shift-Option-C or click the “clear
selection” button. Make sure “Selection Mode” is checked (press Cmd-K or click the
box, if needed). Now click the mouse elsewhere on the timeline (in the appropriate
direction), or move the cursor using key commands, until the selection spans the desired
interval. Finally, create the new annotation here, with the same methods described
earlier (e.g. press Cmd-Option-N). It can be on a separate tier from the one it is next to
(simply make the desired tier Active by double-clicking its name or pressing Cmd-Up /
Cmd-Down).
You can create an annotation directly above or below an existing one, using its boundaries:
• Simply make an existing annotation Active, make sure a different tier is Active, and
create a new annotation in the normal way (press Cmd-Option-N).
You can create new annotations by subdividing an existing one:
• Make sure you are in Normal mode under Options > Propagate Time Changes.
• Make active the annotation you wish to subdivide; this will also create a selection that
fully spans this annotation. Next you will use Selection Mode (press Cmd-K), and cause
the left side of the selection to move further and further to the right (while the end of the
selection remains stationary). As you do so, simply create new annotations (press CmdOption-N) that are each the size of the ever-shrinking selection; when this happens, it
will slice off whatever is to the left side of this selection (i.e., the left-most portion of the
previously created annotation) and leave it in place, while creating a new annotation
within the bounds of the new selection.
• The above process can be used to mark out interlinear glosses (or any other
subcomponents) within the same boundaries of a single large annotation on a different
tier (e.g., a full sentence of speech, or a gesture phrase or unit).
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You can mark out a series of blank annotations during playback:
• Do this only on a blank tier, or in a portion of a tier that does not have annotations
(otherwise existing ones will be overwritten).
• Select Tier > Segmentation... to open the Segmentation window.
• BE SURE TO CHOOSE CORRECT TIER FROM THE PULLDOWN MENU (the first
tier in your list will be selected by default): this is the tier where the annotations will be
created, independent of which tier is currently active in the main window.
• Choose Two keystrokes per annotation if you want to create non-adjacent annotations
by marking out both the beginning and end of each one, or choose One keystroke per
annotation if you want to create adjacent annotations by marking out the boundary
between each annotation as you go along.
• Use the playback controls in the Segmentation Window, and mark out the boundaries of
your annotations as it plays by repeatedly pressing Return. If it looks like it was done
correctly (i.e., in the right tier, etc.), click Apply.
THE ANNOTATION VIEWER
Besides the Timeline, ELAN also provides other ways to view your collection of annotations:
THE ANNOTATION DENSITY VIEWER
• This is the very skinny horizontal bar just above the Timeline and Waveform Viewer. It
represents the entire extent of the Timeline (there is no zoom).
• In the upper half of this skinny bar, any selection will appear as a grey line, with a length
corresponding to the length of the selection.
• In the lower half, all annotations are represented by small tick marks (regardless of the
length of the annotations). With lots of annotations, there are lots of tick marks, hence
you can see the “density” of annotations.
The “Annotation Viewer”, meanwhile, refers to the functions of the upper-right quadrant of the
ELAN window. In addition to the Controls tab, which allows you to control volume level and
playback rate, there are tabs for Grid, Text, and Subtitles. Each one refers to a different way of
viewing your annotations:
• Grid View: shows you annotations for one chosen tier, in a vertical spreadsheet, highlighted
according to which one is selected. You can select any annotation in the list by clicking on it
(which also navigates to this spot in your movie and timeline). The red arrow indicates your
cursor position (either on an annotation or between annotations).
• Text View: shows the text of your annotations (for one chosen tier) in one continuous line,
with each annotation's text separated by a dot. As before, the blue-outlined piece of text
matches the active annotation in the timeline, blue shading represents the current selection, and
the red outline represents the current position of the cursor/crosshair. You can navigate to
different annotations by clicking on them.
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• Subtitles View: this view differs from the others: it only displays annotations that are
currently being intersected by the cursor, i.e. only one annotation at a time for a given tier. But
it can display content for up to four separate tiers at once (select them from the separate pull
down menus). In this way it can serve to display subtitles as you play the movie, because the
displayed info will change as the cursor passes over each annotation. Since this view only
displays the annotation(s) for a single moment in the timeline, you cannot click on it to
navigate around the movie.
OPTIONS FOR “PROPAGATING TIME CHANGES”
When you choose Options > Propagate Time Changes, three options are available:
• Normal: This means “overwrite mode”. Creating a new annotation never moves any
existing ones. If your new annotation overlaps an existing one on the same tier, it will
slice off the overlapping portion when creating the new annotation (the old annotation
will be shortened so that it only occupies the part of its former territory that was not
overlapped). If you completely cover an old annotation with a new one, the old
annotation will simply be deleted.
• Bulldozer Mode: This is one kind of “insert mode”. Creating a new annotation will
move an existing one out of the way only if there is some overlap between them on the
same tier. If your new annotation is placed on completely empty territory, then no other
annotations will be moved, like in Normal mode. Just like a bulldozer, if your new
annotation pushes another one out of the way, the pushed annotation will also push
others out of the way if it hits them because of being moved. If your new annotation
completely overlaps an old one, then the old one will be pushed to the right of the new
one. But if your new annotation only partially overlaps the old one, it will always be
pushed in the direction in which it has a non-overlapped boundary (to the left or the
right, depending on where you place the new annotation).
• Shift Mode: This is the other kind of “insert mode”. This mode is the most risky,
because creating a new annotation shifts all other annotations on all tiers to the right, by
the same amount as the size of the new annotation.
MODIFYING ANNOTATIONS
To modify the text of an annotation, double-click it to use the Inline Edit Box, or use:
• Cmd-Option-M: Open the text box to modify the text of the active annotation.
Commit your changes by pressing Cmd-Return, or cancel by pressing Escape.
• Bug: if you press Option-M instead of Cmd-Option-M, the text box will open but it will
print an unwanted µ character into the box, which you will have to delete before
committing your changes.
• Mac users should cross out “Alt + M” from the list of keyboard shortcuts.
To change the start or endpoint of an annotation:
• Make the annotation Active, change the selection, and press Cmd-Return to make the active
annotation’s boundaries match those of your new selection.
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• The most precise way to adjust a selection is to engage Selection Mode (Cmd-K) and use key
commands to tweak its boundaries, as discussed earlier.
• You can also adjust an annotation’s boundaries by making it Active, holding down Option,
and clicking and dragging on the edge of the annotation.
To move an annotation without changing its total length:
• Make the annotation Active, hold down Option, point at the center of the annotation’s
“I-beam” shape (it should turn green), and click and drag to move the whole annotation.
But some annotations have restrictions on where they can be moved, and on where their
boundaries can be adjusted to (see the following sections for further explanation):
• Annotations on dependent, referring tiers must remain within the boundaries of the
associated annotation on the parent tier.
• Annotations that are not time-alignable cannot have their location or boundaries adjusted
directly, but moving a parent tier’s annotations will automatically update the position of
dependent annotations when they are of the non-time-alignable type.
• When the parent tier’s annotation is moved, dependent annotations that are timealignable will stay in place when possible, but be deleted if the new position of the
parent tier's annotation would place them outside of the boundaries.
To delete an annotation, make it Active and use:
• Option-D: Delete the active annotation.
• You can’t use Cmd-Option-D, because this normally toggles “hide” for the Dock in Mac
OS 10. Mac users should ignore “Command + Alt + D” in the list of key commands.
CREATING TIERS
Tiers are the separate lines of your Annotation Timeline, with their names arranged vertically in a
column on the left side.
Every Tier belongs to a Linguistic Type, which determines (1) its dependencies on other tiers
(i.e., whether it depends on another tier as its parent) and (2) whether it is restricted to a
Controlled Vocabulary (restricting the possible values that can be entered in annotations).
You get to define your linguistic types (i.e., their associated tier dependencies and controlled
vocabularies) however you want. So it's easiest to start with a Template File (type *.etf) which has
a pre-defined structure that fits your annotation goals.
To arrange the display of your tiers:
• Drag tiers up or down in the list (click and drag on the name of a tier in the list at the left of the
annotation timeline).
• Or sort your tiers by hierarchy, linguistic type, or participant by Rt-clicking the tier list and
choosing from the pop-up menu. If a sorting option other than “unsorted” is checked, it will
restrict your ability to freely drag tiers around with the mouse.
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• You can also Rt-click this list to choose which tiers are visible, or to expand/collapse
individual sets of tiers that have sub-tiers (children).
NECESSARY STRUCTURE FOR SETTING UP A TIER
1 - First, you have to have a Controlled Vocabulary or “CV” set up (see below).
2 - This allows you to set up a Linguistic Type (see below) that makes use of that CV.
3 - Finally, you can set up a tier that uses that Linguistic Type.
CREATING A TIER
• Choose Tier > Add New Tier... or press Cmd-T.
• Choose a name.
• Choose the participant (if desired).
• Choose a parent tier for it (if desired).
• Choose a Linguistic Type (your options will vary depending on whether or not you chose a
particular parent tier for it).
• Choose its default language.
• Finally, click Add. You can continue to add more tiers this way; click Close when done.
MODIFYING THE ABOVE PARAMETERS FOR AN EXISTING TIER
• Choose Tier > Change Tier Attributes... You can also Rt-click on a particular tier name in
the list to the left of your Annotation Timeline, and the pop-up menu allows you to change
attributes of that particular tier. Note: some changes will not be possible, if it would invalidate
existing annotations that you have on a tier.
DELETING A TIER
• Choose Tier > Delete Tier... or hit Cmd-Option-T. You can also choose this option by Rtclicking on a tier name in your list.
• Be Careful! – Deleting a tier also deletes any annotations on that tier, as well as any dependent
tiers and their annotations.
TIER DEPENDENCIES
• Choose View > Tier Dependencies... to see your tier hierarchy.
• Nested hierarchies are possible (a child tier can be a parent of other tiers).
• Deleting a parent tier also deletes all of its child (referring) tiers.
• Deleting an annotation from a parent tier also deletes annotations on a child tier that are
associated with the parent tier annotation being deleted.
• Changing the time interval of a parent tier’s annotation also changes that of an associated
annotation on a referring tier (you can’t change the child tier’s annotation’s time interval
independently).
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• To change the parent tier of a dependent child (referring) tier, use the “wizard” accessible from
Tier > Change Parent Of Tier.... Doing so creates a new child tier (including any dependent
referring tiers, if the original had any) and associates it with the newly assigned parent. All the
same annotations as the original are copied over, while leaving the original in place. The newly
created tier will have the same name but with a suffix added (“-cp”, for “copy”). You can then
delete the original if you are satisfied, and remove the “-cp” suffix from the copy.
• Common pitfall: the newly assigned parent MUST have annotations that already overlap with
those of the child tier. Any annotations on the copied child tier which do not overlap with
annotations on the new parent will be deleted!
• But it is safe to take a child tier and turn it into a top-level, independent (parentless) timealignable tier; no annotations will be deleted since independent tiers have no restrictions
regarding where their annotations must line up.
CREATING LINGUISTIC TYPES
Choose Type > Add New Linguistic Type...
• Give the Type a name.
• Choose a Stereotype for it. Choose “none” if it will be for tiers that don’t have a parent. The
other options are useful for Types used by tiers that have parents. In all four cases, the parent
tier must have an annotation on it already before you place an annotation “inside it” on the
child tier, using these Stereotypes:
• Time Subdivision: The large time interval of a parent tier’s annotation is subdivided
into smaller, adjacent intervals on this child tier. The child tier’s annotations are time
alignable, but only within the specific interval already defined by an annotation on the
parent tier. Also, the subdivisions on the child tier are directly adjacent to each other
(with no gaps). This Stereotype is useful, for example, for subdividing a parent
“utterance” annotation into individual words aligned with the moment each is spoken.
• Included In: The child annotations are time-alignable like with Time Subdivision,
except gaps are allowed between the child tier’s annotations. This Stereotype is useful
if you wish to include empty space to represent silence or inactivity between individual
annotations.
• Symbolic Subdivision: Aligns child annotations to endpoints of a parent annotation,
rather than to timecode. This is similar to Time Subdivision in that the child tier’s
annotations are subdivision’s of a larger annotation on the parent tier. But they are not
time-alignable. Note: each new annotation you add will compress existing subdivisions
to accommodate the new one (the subdivisions stay equally spaced in the timeline to fill
the full interval of the parent tier’s associated annotation). To add a new annotation after
the first, you must select it, then choose New Annotation Before (Shift-Cmd-N) or
New Annotation After (Shift-Option-N) from the Annotation menu, rather than the
more commonly used New Annotation Here (Cmd-Option-N).
• Symbolic Association: Forces you to have at most one child annotation per
parent annotation (useful, e.g., if you are marking out grammatical categories for
single morphemes on a parent tier). Or if you are associating exactly one “free
translation” annotation with each utterance annotation of a parent tier. Or if you are
associating exactly one gloss annotation with each word annotation on a parent tier.
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• Choose the Controlled Vocabulary (you should create this beforehand, or create it afterwards
and then go back to modify your Type to use it).
MODIFYING OR DELETING A LINGUISTIC TYPE
• Choose Type > Change Linguistic Type... to modify an existing Linguistic Type.
• Choose Type > Delete Linguistic Type... to delete a Linguistic Type.
CREATING CONTROLLED VOCABULARIES
A Controlled Vocabulary, or “CV”, allows you to restrict a tier’s annotation text to a finite set of
possible values, which you define.
To use a CV, you have to create it or import it, then associate it with a Linguistic Type, and finally
then you can apply it to a Tier (by using that Linguistic Type for the tier).
Choose Edit > Edit Controlled Vocabularies...
• Give it a name and a description, and click Add.
• Now you can type an Entry Value in the box below, and give it a description in the box below
that, and click Add on the button below the Entry description window. Repeat this process
until you have added to the list all the values you want this CV to have enabled.
• Using the pictorial buttons at the bottom, you can also re-order the values, which changes the
order in which they’re offered to you when you’re making annotations later.
• You can also change an existing CV by choosing it from the pull-down list, making alterations,
and clicking the Change button.
• Click Close when finished.
• Now, in the Type menu, you can assign a CV to a particular Type, and any Tier that you
associate with this Type will then have its annotations restricted to the values entered in for the
CV. To make more values possible, you have to edit the CV.
• Once you are using a Tier associated with a Linguistic Type that is assigned a CV, creating
annotations in the timeline (e.g., by pressing Cmd-Option-N) no longer results in a text box.
Instead, you get a pull down menu with the possible CV values, and you can move up and
down the list with the arrow keys and choose a value by pressing Return.
• You can bypass a CV restriction by holding down Shift and double-clicking an annotation:
this allows you to enter in whatever text you wish instead of just choosing from the drop-down
list of possible CV values.
• Note: Possible buggy, unknown side effects may happen if, midstream (after entering
various annotations) you change a Tier so that it has a Type no longer associated with a
CV, and can now have free annotations.
• In general, before doing anything major or unusual with your EAF (annotation file), do a
Save As... to another version number, so that a copy of your original EAF remains.
That is, your first file could be gesture annotation.eaf, but periodically you should use
Save As... and name it gesture annotation v2.eaf, gesture annotation v3.eaf, and
so on, which will create an incremented list of EAF files in your save location.
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CREATING A TEMPLATE FILE (ETF)
Once you have the desired set of Tiers, Linguistic Types, and Controlled Vocabularies, you can
save your structured set as a Template file: choose File > Save As Template... to create an
ELAN Template File (*.etf).
• Modifying a Template File (at least in the safest way) requires a somewhat non-intuitive
method: open a new Annotation File using the Template, make changes to the structure of
Tiers, Types, and CVs, then save it as a Template again.
• Note: Templates are only useful when you first create an Annotation File. You cannot take an
existing Annotation File and apply a new template to it. Similarly, once you create an
Annotation File with a given template, any later changes you make to that Template File will
have no effect on previously created Annotation Files that used the old Template.
COPYING AND PASTING ANNOTATIONS
After selecting an annotation and choosing Copy Annotation (Cmd-C), the command Paste
Annotation (Cmd-V) has a non-intuitive result: the paste includes the time information of the
copied annotation. This is often not useful since you already have the original annotation at the
original time value!
The primary purpose of choosing Paste Annotation or Paste Annotation Group (the options
which preserve the time info of the copied annotations) is to paste annotations into a different
EAF file using the same video. But note you can also import an entire Tier’s contents to that other
EAF via the command Tier > Import Tiers....
• If you want to instead paste an annotation at the crosshair’s position, you need to use Paste
Annotation Here (Shift-Cmd-V). The annotation is pasted at the crosshair’s position on the
active tier. Note that the tier to which you paste must have the same Linguistic Type as the
copied annotation. You can also Rt-click anywhere and choose to Paste Annotation Here
from the pop-up menu, and it is pasted where you clicked (including on the tier where you
clicked, provided it has the proper Type).
To duplicate an annotation (to a different Tier, at the same spot in the timeline), do the following:
• Make the destination Tier active, select the source annotation, and press Cmd-D (or choose
Annotation > Duplicate Annotation). This even works to place an annotation on a tier with a
different type.
To copy and paste an annotation along with associated annotations on child Tiers:
• Choose Annotation > Copy Annotation Group.
• Then choose Annotation > Paste Annotation Group Here to paste them at the crosshair.
TOKENIZING A TIER
Choose Tier > Tokenize Tier...
This feature allows you to take a parent tier that contains annotations with text including spaces or
some other delimiter (e.g., sentences), and use it to create a new child tier which contains separate
annotations for each word. Assign the child tier a Type with Time Subdivision or Symbolic
Subdivision.
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In contrast, if you want to fill in the boxes for a child tier using Symbolic Association (where each
parent annotation is matched with a single child tier annotation), there is no need to tokenize.
Instead, you can use the Grid view in the Annotation Viewer, choose the appropriate parent tier
and click the checkbox (which activates the “multiple tiers” view and only works if you have a
parent tier associated with a child tier that has the type Symbolic Association. You can then click
in the blank boxes of the child tier to fill them in with text.
FILTERING A TIER
Choose Tier > Filter Tier...
Use this command when transferring info from one tier to another which is a Symbolic
Association with it (i.e., with a one-to-one relationship between their respective annotations). The
annotations from the source tier will be copied to the destination tier, minus the items you enter
into the filter. You can do this, for example, if you wish to excise certain items, words, or
characters from the source annotations.
COPYING A TIER
Choose Tier > Copy Tier.
Use this to copy all the content of a tier, including (if desired) all of its dependent child tiers (click
the box Copy depending tiers as well).
CALCULATING ANNOTATION OVERLAPS
Choose Tier > Create Annotations From Overlaps...
This activates a wizard which allows you to specify the tiers from which to create a new tier with
annotations representing overlaps of the annotations of the selected tiers. You can optionally
fill these new overlap-annotations with their duration values (in the time format you choose).
SEARCHING & EXPORTING
This is where the real utility for data analysis in ELAN begins. Consult the main reference manual
or stay tuned for a future tutorial on the subject!

17

